OpenWrt 및 교재 Q&A

그냥 쓰려고 했는데..

페이지 정보

작성자 guest 작성일18-01-23 16:27 조회11,703회 댓글7건

본문

무선 설정을 안하고 쓰다가 너무 귀찮아져서 그만...;;

그래서 무선 설정을 시도... 메뉴가 없다!!!!

1. http://192.168.1.1 접속
2. Network - Wifi 메뉴 선택
3. Device를 Enable로 체크하고 싶지만....
 - 옆에 리스트 박스가 뜨며, 내용에는 --please choose -- 만 있고
  열어보면 아무것도 내용이 없는,....

어떻게 설정해야 하나요..ㅜㅜ

댓글목록

guest님의 댓글

guest 작성일

교수님께서 수업시간에 말씀하시길... 카미카제가 리눅스 커널 2.6으로 업그레이드 하면서 무선인터넷쪽 지원을 제대로 못받았다고 말씀하셨던게 떠오르네요.
참고 하시길..

guest님의 댓글

guest 댓글의 댓글 작성일

교수님께서 말씀하신건 무선랜 동작에 문제가 있으시다고 한것이지 

무선랜을 사용할수 없다고 하신건 아닙니다.

guest님의 댓글

guest 작성일

Note: The brcm47xx still won't work for those of you needing broadcom wifi, stick to brcm-2.4.
We will tell you when it does work.
라네요.

모자란 영어실력이라 번역은...

guest님의 댓글

guest 작성일

"brcm47xx 펌웨어는 broadcom wifi를 필요로 하는 사람들을 위해서는 정상동작하지 않을 것입니다. brcm-2.4 펌웨어를 그대로 사용하세요. 동작하게 되면 알려드리겠습니다"

혹시 그 문제가 해결되었나 해서 구글을 통해 확인해보았는데 해결했다는 메시지는 아직 없습니다.

리눅스 커널 2.4를 설치하려면 ?
교재 P148에 설명되어 있듯이 http://downloads.openwrt.org/kamikaze/8.09/brcm-2.4/ 에 접속하여 openwrt-brcm-2.4-squashfs.trx 다운로드하세요.   

성공하면 댓글 올려주세요

또한 관련 영문 메시지를 웹으로 찾아 위처럼 올린 것에 감사합니다.
누구나 구글검색을 이용하면 관련 정보를 쉽게 찾을 수 있습니다.
이 게시판이 정보공유의 장이 되기를 ....

guest님의 댓글

guest 작성일

공유기가 정상동작하는 상황에서 펌웨어를 쉽게 교체하는 방법이 교재 부록 6(P475) 에 나와 있습니다. 참고하세요

guest님의 댓글

guest 작성일

확실히 2.6 커널에서는 지금 v1도 동작을 안하는군요.

좀더 테스트 해봐야겠지만 교수님께서 말씀하신대로 브로드컴 측에서

2.6 커널에는 오픈한 상태가 아닌 걸로 알고있습니다.

2.4 펌웨어는 확실히 됩니다.

공유기에서 /etc/config/wireless 부분에 설정을 해줘야합니다.

우선,

config wifi-device wl0
        option type broadcom

위 내용만 설정파일(/etc/config/wireless)에 넣어주셔도

웹에서 접속하시면 디바이스 wl0이 생깁니다.

그후에 설정은 하나씩 추가해 주시면 되고요.

웹으로 설정하시고 다시한번 /etc/config/wireless 를 보시는 게 도움이 됩니다.

그럼 수고하세요. ^_^

guest님의 댓글

guest 작성일

글쓴이인데요...

아주 간단한 방법으로 해결했네요...

아수스 공유기의 무선 기능은 포기했습니다..;;

아수스에 WAN을 연결하고 LAN포트 중 한개를

원래 사용하던 공유기의 WAN에 연결, 그 공유기의 Wireless 활용

전혀 문제없이 동작하는군요..

과제할때만 기존 공유기에서 케이블을 뽑아 노트북에 연결후 사용중입니다~