OpenWrt 및 교재 Q&A

네트워크 환경설정에 관한 질문입니다.

페이지 정보

작성자 한군 작성일18-01-24 19:31 조회11,579회 댓글5건

본문

제간 지금 linksys wrt54g에 펌웨어를 올리고 다음

ssh를 이용하여 /etc/config/network 파일을 요구에따라 수정하고

/etc/config/network restart 명령으로 설정파일을 적용할려고

하였더니 계속 멈춘상태입니다. 제가 몇차례를 시도했는데 계속 안되더라구요 왜서인지

알려주시면 감사하겠습니다.


참고로 제가 사용한 올린 펌웨어가

http://downloads.openwrt.org/backfire/10.03/brcm47xx/openwrt-wrt54g-squashfs.bin

입니다.

// 관리자 2018-01-24: 12-11-07 17:03 에 작성된 글입니다

댓글목록

박우재님의 댓글

박우재 작성일

말씀하신 내용을 보고는 진단을 하기가 부족합니다. 무엇을 보고 하셧는지 어떤 명령어를 치셨는지 알려주시거나.

/etc/config/network 의 내용을 넣어 주시기 바랍니다.

그리고 네트워크 리스타트 명령어는

/etc/init.d/network restart 입니다.

// 관리자 2018-01-24: 12-11-08 17:36 에 작성된 글입니다

한군님의 댓글

한군 작성일

제가 아마도 네트워크 설정을 잘못 입력한것 같습니다.

혹시 정확한 네트워크 파일 설정내용을 제공할 수 있을까요! 

AP : Linksys-wrt54g
펌웨어 : backfire 10.03 입니다.

// 관리자 2018-01-24: 12-11-09 15:44 에 작성된 글입니다

한군님의 댓글

한군 작성일

#### VLAN configuration # VLAN 설정
config switch eth0 # 내부 스위치와 eth0가 연결
option vlan0 "1 2 3 4 5*" # 1, 2, 3, 4, 5번 포트가 vlan0으로 tagging
option vlan1 "0 5" # 0, 5번 포트가 vlan1로 tagging
#### Loopback configuration # Loopback 인터페이스 설정
config interface loopback
option ifname "lo"
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
#### LAN configuration # LAN 인터페이스 설정
config interface lan
option type bridge # bridge로 연결되어 있음
option ifname "eth0.0" # eth0.0이 LAN 인터페이스
option proto static # 고정 IP를 사용
option ipaddr 192.168.1.1
option netmask 255.255.255.0
#### WAN configuration # WAN 인터페이스 설정
config interface wan
option ifname "eth0.1" # eth0.1이 WAN 인터페이스
option proto dhcp # DHCP를 통해 동적 IP를 사용

제가 공유 파일에  따라한 설정 파일입니다

// 관리자 2018-01-24: 12-11-09 16:00 에 작성된 글입니다

박우재님의 댓글

박우재 작성일

#커널 모듈에 올라와 있는 네트워크 장치들을 확인하시려면 dmesg를 확인합니다.

root@OpenWrt:/etc/config# dmesg|grep eth
Realtek RTL8366S ethernet switch driver version 0.2.2
eth0: Atheros AG71xx at 0xb9000000, irq 4
eth0: using fixed link parameters
eth1: Atheros AG71xx at 0xba000000, irq 5
eth1: connected to PHY at rtl8366s:04 [uid=001cc960, driver=Realtek RTL8366S]
eth0: link up (1000Mbps/Full duplex)
eth0: link down
eth0: link up (1000Mbps/Full duplex)
device eth0.1 entered promiscuous mode
device eth0 entered promiscuous mode
br-lan: port 1(eth0.1) entering forwarding state
eth1: link up (1000Mbps/Full duplex)

#proc 디렉토리는 현재 올라와 있는 네트워크 인터페이스를 확인할 수 있습니다.

root@OpenWrt:/etc/config# cat /proc/net/dev_mcast
2    eth0            2    0    000000000000
3    eth1            1    0    000000000000
4    eth0.1          2    0    000000000000
5    br-lan          1    0    000000000000
8    wlan0          2    0    000000000000

root@OpenWrt:/etc/config# cat /proc/net/arp
IP address      HW type    Flags      HW address            Mask    Device
000000000000    0x1        0x2        000000000000    *        br-lan
000000000000    0x1        0x2        000000000000    *        eth1
root@OpenWrt:/etc/config#


#linksys 설정 링크

http://wiki.openwrt.org/toh/linksys/wrt54g#specific.configuration


// 관리자 2018-01-24: 12-11-10 06:41 에 작성된 글입니다

박우재님의 댓글

박우재 작성일

정 안되시면 아래 쉡스크립트 받으셔서 네트워크 설정 복구해 보시기 바랍니다.


https://dev.openwrt.org/browser/trunk/target/linux/brcm47xx/base-files/etc/init.d/netconfig

// 관리자 2018-01-24: 12-11-10 06:48 에 작성된 글입니다